読者です 読者をやめる 読者になる 読者になる

仕事やプライベートで調べたことのメモ書きなど(@札幌)

仕事やプライベートで調べたこと、興味ある事のメモ書きです。2016年4月から札幌で働いてます。※このブログは個人によるもので、団体を代表するものではありません。

プラグインのインストールでgemがエラー(Windows PC)

Windows 仕事

さて、fluentdで収集したログをmongoに突っ込むぞ、と思ったところ、プラグインのインストールでgem installがエラー。
以下と同じ状況だったのでgemをupdateしてみました。
qiita.com

これに従って、アップデートすると・・・、なんと無事プラグインがインストールできましたとさ。

C:\fluentd>gem install fluent-plugin-mongo
Fetching: bson-1.12.5.gem (100%)
Successfully installed bson-1.12.5
Fetching: mongo-1.12.5.gem (100%)
Successfully installed mongo-1.12.5
Fetching: fluent-plugin-mongo-0.7.16.gem (100%)
Successfully installed fluent-plugin-mongo-0.7.16
Parsing documentation for bson-1.12.5
Installing ri documentation for bson-1.12.5
Parsing documentation for mongo-1.12.5
Installing ri documentation for mongo-1.12.5
Parsing documentation for fluent-plugin-mongo-0.7.16
Installing ri documentation for fluent-plugin-mongo-0.7.16
Done installing documentation for bson, mongo, fluent-plugin-mongo after 11 seconds
3 gems installed

C:\fluentd>